[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#39794: AVR-Toolchain-5 avr/io not found

From: Ekaitz Zarraga
Subject: bug#39794: AVR-Toolchain-5 avr/io not found
Date: Fri, 28 Feb 2020 22:42:15 +0000

I'm checking the output by avr-gcc-4.9 in order to compare, and it doesn't have 
the stubs-32.h file neither but the compilation with avr-gcc-4.9 doesn't ask 
for it so it doesn't break.

Instead, if I use avr-gcc-5 it asks for the stubs-32.h file and it fails 
because it's not installed.

Both of them must be checking stubs.h (maybe the compilation with 4.9 isn't?) 
file that makes the include of the -64 or the -32 depending on the platform :S

Also I tried compiling glibc for 32 bytes because stubs-32 is on it. It worked 
but carried a different error, probably because I didn't compile it correctly:

error: unknown type name '__float128'

This error shouldn't happen because the bits/floatn.h file is making checks 
before doing the typedef that fails... So there are a couple of options here:
- The checks are not enough to find my case
- I made the 32 bit GLIBC wrong and it's carrying wrong parameters to that 
header file, and makes it fall in a weird case.




ElenQ Technology
Ethical Innovation

reply via email to

[Prev in Thread] Current Thread [Next in Thread]