[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#35561: Fresh install, guix pull exits with error, hash mismatch

From: Ludovic Courtès
Subject: bug#35561: Fresh install, guix pull exits with error, hash mismatch
Date: Tue, 07 May 2019 10:13:04 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.2 (gnu/linux)


Calle Kabo <address@hidden> skribis:

> I tried running guix pull again, but still didn't work
> https://paste.debian.net/1081770

This shows that substitutes were not used:

--8<---------------cut here---------------start------------->8---
41 building 
42 downloading from https://letsencrypt.org/certs/letsencryptauthorityx4.pem...
43 |sha256 hash mismatch for 
44   expected hash: 003dc94c8qwj634h0dq743x7hqv9rdcfaisdksprkmi2jd107xq4
45   actual hash:   0giiixknr0mls2ir6qqzb42mq7x9a7vz79gbn7fjszbf87pqhpzm
--8<---------------cut here---------------end--------------->8---

That’s why you get the exact same result as before.

The reason substitutes were not used is that Guix cached the fact that
substitutes weren’t available.  They became available in the meantime
but the cached entry hasn’t expired yet.

To work around it, you could wait some more :-), or you can do:

  guix pull --substitute-urls=https://berlin.guixsd.org

berlin.guixsd.org provides the same contents as ci.guix.gnu.org.
However, that will trick Guix into building a fresh cache for that

Let us know how it goes!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]