[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#35560: GNOME Shell 3.28 crashes and suspends to RAM (!) after ejecti

From: Mark H Weaver
Subject: bug#35560: GNOME Shell 3.28 crashes and suspends to RAM (!) after ejecting removable media
Date: Sat, 04 May 2019 15:27:08 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.2 (gnu/linux)

Ludovic Courtès <address@hidden> writes:

> GNOME Shell is crashy since the 3.28 upgrade (it’s an install that was
> made before the 3.28 upgrade; I wonder whether the same happens on a
> fresh install.)
> It occasionally crashes (SIGSEGV) and is automatically respawned, which
> is kinda okay: as a user, you notice that it flickers for a second or
> two and then it comes back.

FWIW, I've found GNOME Shell to be quite solid on my X200, including
since the 3.28 upgrade.  However, I run it under Wayland, by running
"XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session" from a
text console.  Perhaps that makes a difference?

> The thing that’s really bad is that clicking on the eject icon of a
> removal storage device in Files leads to a gnome-shell crash that’s
> unrecoverable (“respawning too quickly”), followed by the laptop
> entering suspend-to-RAM without prior notice (!):

I just tried this, and it works fine for me.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]