[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#35379: Long lines in `guix` output are truncated at screen width

From: rendaw
Subject: bug#35379: Long lines in `guix` output are truncated at screen width
Date: Wed, 24 Apr 2019 03:30:17 +0900
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.5.3

On 4/23/19 10:13 PM, Ludovic Courtès wrote:
> Hi rendaw,
> rendaw <address@hidden> skribis:
>> I get logs like:
>> /gnu/store/6zkimxsfyn0gdc7p4ikxlrhilpnpblsi-grub-efi-2.02/sbin/grub-install:
>> error:
>> /gnu/store/6zkimxsfyn0gdc7p4ikxlrhilpnpblsi-grub-efi-2.02/lib/grub/i386-pc/modinfo.sh
>> doesn't exist. Please spe.
> Hmm weird.  Can you tell exactly how to reproduce this issue?
> I don’t see what could be truncating these lines.
> Thanks in advance,
> Ludo’.

I thought this was normal, but I tried reproducing it in a vm.

It appears that the truncation starts after qemu starts the image in


guix system disk-image my-config.scm -v 10


and the truncation continues thereafter.  I tested by doing:


(display (iota 200))

(display "\n")


(display (iota 200))


This prints before and after the qemu step of the build.  Before the
qemu process it looks like lines are wrapped properly.  After the qemu
process the lines are truncated.  And lines are truncated before+after
for subsequent builds until I reset the vm.

I can send the Vagrantfile and provisioning script + what I did manually
to do the build if you'd like.

The main issue is the build fails, I turn -v 10 on to see the verbose
logs, but then the logs I need (during/post qemu) are truncated so I'm
still not getting the important information.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]