[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#26659: address@hidden: Re: fonts bug in icecat?]

From: Chris Marusich
Subject: bug#26659: address@hidden: Re: fonts bug in icecat?]
Date: Sun, 30 Apr 2017 13:37:18 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

ng0 <address@hidden> writes:

> Here is a visual display of some fonts: https://ptpb.pw/EQfV.png
> This is either related to icecat changes or to changes with font
> related packages.

The same page (presumably http://www.bbc.com/) renders fine for me; no
boxes, all glyphs appear to be rendered correctly.  In addition, system
fonts appear to be selectable for me in icecat.  See attached files for

I have not run 'guix pull' in the last week or two.  Would you like me
to tell you anything about my system's configuration that might shed
light on the issue?  I'm going to update my system later today, so if
there are any problems (or not), I'll let you know.

Maxim Cournoyer <address@hidden> writes:

> On Wed, Apr 26, 2017 at 2:05 PM, ng0 <address@hidden> wrote:
> [...]
>>> >ng0 transcribed 1.1K bytes:
>>> >> Were you (or someone else) able to reproduce this?
>>> I never got the Japanese fonts working on GuixSD by following our info 
>>> manual, and this was before those updates.
>> Can you tell me exactly or roughly what you tried and what errors (not 
>> specific, in general) you
>> see in the current functioning system? It would be useful to get a clear 
>> view on
>> languages / localization specific issues to improve the system.
> I don't recall seeing any particular errors, I had simply followed
> section 2.6.3 X11 Fonts [1] and installed the suggested fonts using:
> "guix package -i font-adobe-source-han-sans:jp".
> Japanese characters were still displayed as boxes (with unicode? in
> them) in any software I tried following a system reboot (gnucash,
> icecat, etc.).
> [1]: https://www.gnu.org/software/guix/manual/guix.html

FWIW, Japanese fonts work for me in all applications I have tried so
far, which includes Icecat, GNOME terminal, graphical emacs, and Gedit,
all on GNOME.  I don't recall doing anything that wasn't described in
the manual.

If you're interested in troubleshooting it, I'd like to help you get
Japanese fonts working.  For starters, maybe this information will help:

--8<---------------cut here---------------start------------->8---
$ guix package --list-installed | grep font
font-gnu-freefont-ttf   20120503        out     
font-inconsolata        0.80    out     
font-liberation 2.00.1  out     
font-adobe-source-han-sans      1.004   out     
font-terminus   4.40    out     
font-dejavu     2.37    out     
gs-fonts        8.11    out     
--8<---------------cut here---------------end--------------->8---

I see that I am not using the "jp" output of font-adobe-source-han-sans;
perhaps you can try again using the "out" output?


Attachment: bbc-in-other-languages.png
Description: PNG image

Attachment: icecat-screenshot.png
Description: PNG image

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]