[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-gsrc] util-linux glitch, solved

From: Brandon Invergo
Subject: Re: [bug-gsrc] util-linux glitch, solved
Date: Sat, 19 Jan 2013 11:08:33 +0100
User-agent: Notmuch/0.14 (http://notmuchmail.org) Emacs/24.2.1 (x86_64-unknown-linux-gnu)


carl <address@hidden> writes:

> While installing util-linux:
> configure: error: login selected, but required PAM header file not
> available
> make: *** [configure-work/util-linux-2.22.1/configure] Error 1
> make: Leaving directory `/opt/gsrc/trunk/deps/util-linux'
> I'm using Debian. I did a:
> apt-get install  libpam0g-dev
> and the problem went away.

Ok, I missed that dep because in Parabola the dev files aren't in
separate packages like in Debian. I've also updated the package
to 2.22.2.

I've added pam as an "external" dependency; i.e. you'll still have
to install it via apt but now you'll get a message from GSRC about what
to install. FYI, I'll probably move all non-GNU deps to being such
external dependencies since I have no good way of keeping up with all of
them. I'd rather focus my efforts on the GNU packages.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]