[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gsl] `fprnd_t' undeclared - can't this be solved with autoconf?

From: Dr. David Kirkby
Subject: Re: [Bug-gsl] `fprnd_t' undeclared - can't this be solved with autoconf?
Date: Mon, 27 Sep 2010 09:00:08 +0100
User-agent: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv: Gecko/20100214 Thunderbird/3.0.1

On 09/27/10 12:28 AM, Dr. David Kirkby wrote:
On 09/26/10 05:37 PM, Brian Gough wrote:
I agree, if you can make a patch that handles this without breaking
anything else I will add it. As I don't use AIX I was not in a
position to do that.

I've taken a quick look, and it does not look that hard to solve. One
needs to check if 'fprnd_t' is defined in math.h. If not, it is defined
as an unsigned short. There's a couple of more thinks like that. Once I
get get it working, I'll test it on AIX 6.1 and try to get others with
AIX to test it too.


I seem to have hit a very early problem. Literally just touching 'configure.ac' then using 'autoreconf' to regenerate the configure script gives a non functional makefile

address@hidden:~/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src$ make
make  all-recursive
make[1]: Entering directory `/export/home/drkirkby/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src'
Making all in gsl
make[2]: Entering directory `/export/home/drkirkby/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src/gsl'
rm -f gsl*.h
HEADERLIST="../gsl*.h ../*/gsl*.h"; \
        for h in $HEADERLIST; do \
          BASENAME=`basename $h`; \
          test -r $BASENAME || ln -s $h $BASENAME; \
make[2]: Leaving directory `/export/home/drkirkby/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src/gsl'
Making all in utils
make[2]: Entering directory `/export/home/drkirkby/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src/utils' /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -g -O2 -MT placeholder.lo -MD -MP -MF .deps/placeholder.Tpo -c -o placeholder.lo placeholder.c
mv -f .deps/placeholder.Tpo .deps/placeholder.Plo
mv: cannot access .deps/placeholder.Tpo
make[2]: *** [placeholder.lo] Error 2
make[2]: Leaving directory `/export/home/drkirkby/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/drkirkby/sage-4.6.alpha1/spkg/standard/gsl-1.14.p2/src'
make: *** [all] Error 2

How did you generate the configure script? Was it hand-edited in any way?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]