bug-gsl
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gsl] gsl with cblas patch


From: Brian Gough
Subject: Re: [Bug-gsl] gsl with cblas patch
Date: Sun, 01 Feb 2009 16:57:27 +0000
User-agent: Wanderlust/2.14.0 (Africa) Emacs/22.2 Mule/5.0 (SAKAKI)

At Wed, 21 Jan 2009 19:46:03 +0000,
S├ębastien Fabbro wrote:
> There may be a better way to make sure that gsl links with as-needed
> than the proposed patch. Also switching dynamically the cblas
> library at run time is not allowed because of the cblas library soname
> added at link time (added by @CBLAS_LINK_LIBS@ in libgsl_la_LIBADD).

I recommend applying the patch downstream until the updated version of
ld is availablem when it won't be needed anymore.  That change to ld
should also fix any other packages with the same problem.

-- 
Brian Gough
(GSL Maintainer)

Support freedom by joining the FSF!
http://www.fsf.org/associate/support_freedom/join_fsf?referrer=37




reply via email to

[Prev in Thread] Current Thread [Next in Thread]