[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gsl] gsl on intel macs

From: Richard Neher
Subject: [Bug-gsl] gsl on intel macs
Date: Sun, 12 Feb 2006 14:32:40 +0100

Dear gsl-team,

I am a great fan of gsl, but when I tried to compile gsl (1.6, I also tried 1.7 and 1.4) on my new dual core imac (the one with intel processors) I got the following error message:

Making all in ieee-utils
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. - I.. -g -O2 -c -o fp.lo `test -f 'fp.c' || echo './'`fp.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -g -O2 -c fp.c -o fp.o
fp-darwin.c: In function 'gsl_ieee_set_mode':
/usr/include/architecture/ppc/fp_regs.h:132: error: output constraint 0 must specify a single register
fp-darwin.c:95: confused by earlier errors, bailing out
make[2]: *** [fp.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I understand that it has something to do with the architecture, but am otherwise clueless.

I would really appreciate some help on that, since many of my programms rely on gsl.

Thank you in advance,

Richard Neher

reply via email to

[Prev in Thread] Current Thread [Next in Thread]