[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #59480] error: locale file not found

From: Radoslav
Subject: [bug #59480] error: locale file not found
Date: Wed, 18 Nov 2020 07:49:51 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0


                 Summary: error: locale file not found
                 Project: GNU GRUB
            Submitted by: rado84
            Submitted on: Wed 18 Nov 2020 12:49:49 PM UTC
                Category: Booting
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
                 Release: other
         Discussion Lock: Any
         Reproducibility: Every Time
         Planned Release: None



Until yesterday I had a GTX 1050 Ti installed. Then I bought and installed GTX
1660 Ti and this is where the weird stuff began. When 1050 is installed
everything is OK. But with 1660 grub first look like the attached screenshot.
1 or 2 seconds pass and then the actual grub menu appears where I can choose
an operating system to boot.
I'm using Linux for 4 years and have never seen Bulgarian text in the grub
menu which is why this error puzzles me. On top of that it's looking for a
file extension 'gmo', not 'mo'.

In order to be sure in the error I removed the 1660 Ti and installed 1050 Ti
back into the computer, then booted the system. This error didn't show up. I
put back the 1660 Ti and the error returned. My best guess is that this is
some kind of a grub2 error but what causes it (other than changing video
cards) I have no idea.

Grub version is:
[rado@arch]: ~>$ search grub
core/grub 2:2.04-8 [installed]

P.S. I tried some crude fix which worked for a while. But only for a while. I
took the file uk.mo, renamed it to bg.gmo and put it back in
/boot/grub/locale. At first it seemed to work and the error didn't appear
anymore but then somehing else happened - the grub menu explanation (the one
that describes how to use arrows to select an OS) became in something similar
to a Russian language but not exactly Russian. So I removed the fake bg.gmo
file, the description reverted back to English and the error about missing
bg.gmo file returned.

My system information just in case you need it:

[rado@arch]: ~>$ sysinfo
 OS: Arch Linux 
 Kernel: x86_64 Linux 5.9.8-arch1-1
 Uptime: 43m
 Packages: 1219
 Shell: bash
 Resolution: 1920x1080
 DE: Cinnamon 4.6.7
 WM: Muffin
 WM Theme: Mint-Y-Brownish-v4.4_for-Cinnamon_by-rado84 (Cinnamox-Rhino)
 GTK Theme: Mint-Y-Brownish-v4.4_for-Cinnamon_by-rado84 [GTK2/3]
 Icon Theme: Humanity-Dark
 Font: Noto Sans Bold 10
 Disk: 830G / 1,5T (58%)
 CPU: Intel Core i7-4770 @ 8x 3.4GHz [28.0°C]
 GPU: GeForce GTX 1660 Ti
 RAM: 2156MiB / 32032MiB


File Attachments:

Date: Wed 18 Nov 2020 12:49:49 PM UTC  Name: grub@error@gmo@file@not@found.png
 Size: 217KiB   By: rado84



Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]