[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

initramfs freeze with Grub 2.04 on Ubuntu 20 and Mint 20

From: Yoann Maheo
Subject: initramfs freeze with Grub 2.04 on Ubuntu 20 and Mint 20
Date: Thu, 16 Jul 2020 22:52:37 +0200


Last week end, I tried to upgrade from Mint 19.3 to Mint 20. After upgrading, grub menu was displayed, but the boot was just freezing right after "Loading initial ramdisk".
I tried lots of kernel options, without any success.
Mint 19.3 Live usb key was booting, Mint 20 not. Ubuntu 20 too was freezing.

My system is an Asus Pro Art PA90, system details at the end of the message.

At one time, I boot on Mint 19.3 live key (Grub 2.02), type "c" for Grub command, and type :

set prefix=(hd0,gpt2)/grub
set root=(hd0,gpt2)
insmod linux
insmod normal

Then I get the Mint 20 menu, and select to start Mint in recovery mode

And it works !

Since I succeed to start the system, I removed the Grub 2.04 and replace it by old Grub 2.02

wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2/grub-common_2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2/grub-efi-amd64-bin_2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2/grub-pc-bin_2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2/grub-efi-amd64_2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2/grub-pc_2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2/grub2-common_2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub2-signed/grub-efi-amd64-signed_1.93.16+2.02-2ubuntu8.15_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/grub-gfxpayload-lists/grub-gfxpayload-lists_0.7_amd64.deb
# remove current Grub 2.04
sudo apt-get purge grub-gfxpayload-lists grub-pc-bin grub2-common grub-pc grub-efi-amd64-signed shim-signed
# install Grub 2.02
sudo dpkg -i *.deb


grub-install /dev/sda


My system now boot in with the "fail safe" option.

I'm not sure if this is a bug related to Ubuntu or Grub, but installing old Grub version fixed my issue.

Thanks !

System: Host: XXXX Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine: Type: Desktop System: ASUSTeK product: MINIPC PA90 v: 1001 serial: <filter>
Mobo: ASUSTeK model: PA90 v: Rev 1.xx serial: <filter> UEFI: ASUSTeK v: 1001
date: 03/15/2020
Battery: Device-1: hidpp_battery_0 model: Logitech Wireless Illuminated Keyboard K800
serial: <filter> charge: 55% status: Discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master serial: <filter>
charge: 55% status: Discharging
CPU: Topology: 8-Core model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Kaby Lake
rev: C L2 cache: 16.0 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 115200
Speed: 4654 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 4671 2: 4700 3: 4701
4: 4703 5: 4786 6: 4782 7: 4776 8: 4700 9: 4642 10: 4781 11: 4792 12: 4781 13: 4741
14: 4701 15: 4755 16: 4725
Graphics: Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:3e98
Device-2: NVIDIA GP104GL [Quadro P4000] driver: nouveau v: kernel bus ID: 01:00.0
chip ID: 10de:1bb1
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
resolution: 3840x2160~60Hz
OpenGL: renderer: NV134 v: 4.3 Mesa 20.0.8 direct render: Yes
Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:10f0
Sound Server: ALSA v: k5.0.0-32-generic
Network: Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 4000
bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: down mac: <filter>
Device-2: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: efa0
bus ID: 00:1f.6 chip ID: 8086:15bc
IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 2.21 TiB used: 8.15 GiB (0.4%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-00000 size: 476.94 GiB
speed: 31.6 Gb/s lanes: 4 serial: <filter>
ID-2: /dev/sda type: USB vendor: SanDisk model: Ultra II 960GB size: 1.75 TiB
serial: <filter>
Partition: ID-1: / size: 1.69 TiB used: 7.93 GiB (0.5%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 897.3 MiB used: 168.8 MiB (18.8%) fs: ext4 dev: /dev/sda5
ID-3: swap-1 size: 31.59 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
USB: Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 chip ID: 1d6b:0002
Device-1: 1-2:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
driver: logitech-djreceiver,usbhid rev: 2.0 chip ID: 046d:c52b
Hub: 1-3:3 info: Texas Instruments TUSB8041 4-Port Hub ports: 4 rev: 2.1
chip ID: 0451:8142
Device-2: 1-14:4 info: Intel type: Bluetooth driver: btusb rev: 2.0 chip ID: 8087:0aaa
Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 chip ID: 1d6b:0003
Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002
Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 chip ID: 1d6b:0003
Device-3: 4-1:2 info: SanDisk type: Mass Storage driver: uas rev: 3.1
chip ID: 0781:5593
Sensors: System Temperatures: cpu: 61.0 C mobo: N/A gpu: nouveau temp: 52 C
Fan Speeds (RPM): cpu: 0 gpu: nouveau fan: 3443
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
1: deb [arch=amd64] http: //dl.google.com/linux/chrome/deb/ stable main
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //mirrors.evowise.com/linuxmint/packages tricia main upstream import backport
2: deb http: //fr.archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
3: deb http: //fr.archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
4: deb http: //fr.archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
6: deb http: //archive.canonical.com/ubuntu/ bionic partner
Active apt repos in: /etc/apt/sources.list.d/skype-unstable.list
1: deb [arch=amd64] https: //repo.skype.com/deb unstable main
Info: Processes: 405 Uptime: 14m Memory: 31.26 GiB used: 2.24 GiB (7.2%) Init: systemd v: 237
runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Client: Unknown python3.6 client inxi: 3.0.32

reply via email to

[Prev in Thread] Current Thread [Next in Thread]