[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #43062] boot-directory not in core.img

From: Jay Michael
Subject: [bug #43062] boot-directory not in core.img
Date: Sun, 24 Aug 2014 05:18:18 +0000
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0


                 Summary: boot-directory not in core.img
                 Project: GNU GRUB
            Submitted by: jmichael
            Submitted on: Sun 24 Aug 2014 05:18:18 AM GMT
                Category: Configuration
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Jay Michael
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 2.02~beta1
         Reproducibility: Every Time
         Planned Release: None



     The boot-directory doesn't seem to be getting into the core.img produced
by running grub-install.

     I'm using an Ubuntu 14.04 Live CD (DVD), or Live USB, on a Dell 2330
All-in-One.  Eventually, I want to install Linux to an external USB drive. 
Right now, I'm just trying to make sure that I can boot from the drive, a
Western Digital 3TB MyBook -- my first external drive, a Seagate 2TB Expansion
Desktop, seemed to be completely unbootable (as in never offered as an option
in the list of devices from which to boot in BIOS setup, and as in Seagate
says it "wasn't designed to be used as a boot device").

     The first partition on the WD drive is a 2GB FAT16, label VDOS.  I run
          grub-install --boot-directory=${VDOS}/boot /dev/sdc
and get a /boot/grub on the VDOS partition.
     When I boot and go to the BIOS boot options and select the WD drive, I
get a message telling me to insert the correct disk[?] and hit any key, or
reboot and pick another device.  It's the same message I get when I tried
booting before I tried to put a boot loader on the drive.  It does not seem to
be any kind of GRUB prompt.

     When I run bootinfoscript, the Boot Info Summary says:

=> Grub2 (v1.99) is installed in the MBR of /dev/sdc and looks at sector 1 of

    the same hard drive for core.img. core.img is at this location and looks 
    in partition 112 for .

     I've seized on this as the next problem I need to fix.  I don't know if
bootinfoscript can be trusted -- it seems to be reporting GRUB 1.99, when I'm
using 2.02~beta2-9.

     I saw the bug report about a disk with a 4K block size, but that report
said there was a grub error message -- I get none.

* grub-install.log
output of grub-install --debug --force --no-floppy --recheck
--boot-directory=/media/ubuntu/VDOS/boot /dev/sdc 2>&1
* grub-install.bisresults
RESULTS.txt from bootinfoscript
* core.img from ${VDOS}/boot/grub/i386-pc


File Attachments:

Date: Sun 24 Aug 2014 05:18:18 AM GMT  Name: grub-install.log  Size: 96kB  
By: jmichael

Date: Sun 24 Aug 2014 05:18:18 AM GMT  Name: core.img  Size: 24kB   By:

Date: Sun 24 Aug 2014 05:18:18 AM GMT  Name: grub-install.bisresults  Size:
24kB   By: jmichael



Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]