[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub install on usb floppy

From: Cris
Subject: grub install on usb floppy
Date: Tue, 4 Mar 2008 14:59:15 -0300

I found several cases of differences between the behavior of grub and
it's description in the manual.

I'm trying to install linux on a pen-drive, which is recognized by my
BIOS as a floppy, not a hard-drive. I have two computers like that,
one calling it USB-FDD, the other USB RMV-FDD. If I partition the
pen-drive, grub is found (for being on the master boot record), but
doesn't seem to be able to find stage2. I didn't follow this longer,
because the BIOS is clearly stating, that it will consider a pen-drive
to be like a floppy disk and not a hard drive. About two years ago, I
already had such a situation, but I can't recall how I solved it.

The first thing I tried to do was to install a regular linux from an
installation CD. This won't allow to consider the pen-drive as a
floppy, so a one partition system was installed, including grub on the
master boot record. I already knew, that this wouldn't boot. I've seen
different messages, but right now, I got "GRUB Hard Disk Error".

Then, a second pen-drive, mkfs.ext3 formatted /dev/sdc, which was
mounted at the same time as the former, and the all files where copied
preserving dates and permissions. Then sdc was attached to a loop back
device before running the grub shell:

        # grub --device-map=/dev/null
        grub> device (fd0) /dev/loop0
        grub> root (fd0)
        grub> setup (fd0)
        grub> quit

At least, this was the plan. The first line was accepted without
complaints, just an empty line. The second line responded with:

        fd0Unknown partition table signature
        Filesystem type is ext2fs, using whole disk

Both messages are bugs in grub. If fd0 is the official name for a
floppy disk, it makes no sense that grub is searching any partition.
Also, the file system type was ext3, which should work with grub, as
debian installs ext3 by default using grub. This was done on a debian
unstable installation, using grub 0.97-32. The third already gave

        Error 16: Inconsistent filesystem structure

after telling that there is no stage1/stage2 file on this drive (which
is incorrect).

It seems that there is no way to convince grub that a floppy does not
have partitions. I also tried to create a pen-drive with a Grub Boot
Floppy, following the steps of chapter 3.1 of the manual. I used stage1
and stage2 from debian unstable (0.97-32) and stable (0.97-27), using
the images as delivered by debian and compiling from the debian source.
In all cases, the size of stage2 was different. With the debian
delivered stage2, grub prints "Loading stage2..." and hangs there. With
all other stage2 images, the same is printed, then the CD is accessed,
the computer is rebooted, and everything starts all over.

Is this really a bug in grub or am I doing something wrong? Which is
the correct form to convince grub that an usb pen-drive can have no
partition at all? Am I the only one having an AMI BIOS which insists in
the USB-FDD thing and wanting a pen-drive with grub to be able to reboot
a system (or having a whole Linux in a 4gb drive)?

Thanks for any help,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]