[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No tab completion

From: Adrián
Subject: Re: No tab completion
Date: Mon, 30 Oct 2006 20:43:09 +0100 (CET)
User-agent: SquirrelMail/1.4.4

> Hello,
> I have fedora 6 on x86_64; I ran "grub" from terminal, enter  grub> .
> I ran "tab" and DON'T see a list of commands.
> Also I try grub>root(hd0,0)/ and tab

you cannot root to anything but hard disk or partition

> but there is no TAB completion.
>  also none on grub> root (hd0,1)/ and so on
> also grub>root(<tab>    gives nothing!
Here, yes, you should see something.
> Why ? Any idea?
> Ian

If you say that you run grub from terminal it might happen that device.map
(/boot/grub/) is not well made. And thus hd0 does not represent anything
to grub. Maybe you have only the fd0 entry?

Try this.

grub>device (hd0) /dev/sda

Where /dev/sda is your hard disk device in linux
and then try the TAB thing.

Other answers:
2) TAB is not well configured on your system.
3) Fedora have their own patches and they have not applied the
auto-completion tab.
4) Running Grub inside a terminal does not allow you to autocomplete? (I
do not think so :))


reply via email to

[Prev in Thread] Current Thread [Next in Thread]