[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Booting solaris from linux on a dual-boot machine with linux GRUB MBR :

From: Ian Brown
Subject: Booting solaris from linux on a dual-boot machine with linux GRUB MBR : a difficult question
Date: Sat, 28 Oct 2006 15:37:02 +0200

This may seem be a somewhat difficult (at least to me ) and long question;
Hope you can help.

I have Feodra Core 6 on x86_64.
The grub there is from default installation rpm ,grub-0.97-13.

I had installed linux AFTER I hade installed solaris on this
machine. Now I want to be able to boot solaris from it.

I boot my disk from linux.

fdisk -l shows:

  Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        3824    30716248+   c  W95 FAT32 (LBA)
/dev/sda2            3825        3837      104422+  83  Linux
/dev/sda3            3838       10211    51199155   83  Linux
/dev/sda4   *       10212       15312    40973782+  bf  Solaris

Now, as you can see, /dev/sda4 is the solaris partition ; it is also
the boot partition.

It also has a GRUB installed on it,
which was installed when the operating system was installed.
I assume the linux installation did not destroy it
(BTW,I used the Fedora Core default GRUB installation,
so the linux GRUB was installed in the MBR).

When I run:
file -s /dev/sda4
I get:
/dev/sda4: x86 boot sector, GRand Unified Bootloader (0.94);
partition 1: ID=0xc, starthead 1, startsector 63, 61432497 sectors;
partition 2: ID=0x83, starthead 254,
startsector 61432560, 208845 sectors;
partition 3: ID=0x83, starthead 254, startsector 61641405, 102398310 sectors;
partition 4: ID=0xbf, active, starthead 254, startsector 164039715,
81947565 sectors, code offset 0x48

when I run: dmesg |grep solaris , I get:
sda4: <solaris: [s0] sda5 [s1] sda6 [s2] sda7 [s3] sda8 [s5] sda9 [s7] sda10 >

I tried mounting the solaris partitions from linux , /dev/sda5-sda/sda10,
by: mount -t ufs -o ro /dev/sda[1-5] /mnt/solaris[1-5]
but I get error (mount: wrong fs type, bad option, bad superblock on
; (this was done after ufs was modprobed succesfully, needless to say).
However, this seems a BUG in Fedora Core on x86_64, bacause
with Feodora Core 6 Live-CD I am ***ABLE** to mount these UFS solaris partitions
and navigate to my files there, etc. I aslo can boot from solaris USB livecd
and view the solaris partitions; so I am sure that nothing there in the
solaris partitions/slices themselves is damaged.

By the way, at a different machine in the lab we did install first
linux and than
solaris , and we could boot solaris from linux and linux from solaris
(we could also mount
each one from the other , but only as read-write).

Now , my question is : As I know, linux grub does not support UFS.
The solaris grub includes patches to support UFS, but these
patches were not sent upstream and are not part of the official GRUB.
 Upon boot the GRUB of linux is started (it is in the MBR).
I want that it will be able to boot solaris.
what is the solution for this ? Is it possible at all ?
I though of chainloading , so that linux GRUB will
start solaris GRUB , and I made
some trial of chainloading but it did not work; maybe I am missing something ?
More specifically, one trial that I did and seems logical (or maybe not ? I'm
not sure) was:
From the grub menu, is this:
chainloader +1

And I got:
 Invalid or unsupprted executable format.

Any idea what I should do?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]