[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error 18

From: Alexey Toptygin
Subject: Error 18
Date: Tue, 18 Jul 2006 04:55:28 +0000 (UTC)


I have an older IDE drive, a Seagate ST51080A. It responds to probes as CHS=2100/16/63 (both according to BIOS autodetection and to the linux kernel's /proc/ide/hda/gemoetry 'physical' line), but the drive sticker has 2096/16/63 written on it. badblocks -w reports that all 2100 cylinders are OK. I've tried booting from it with grub 0.97-12 from Debian install media on 2 different pentium systems, but I get Error 18 in all cases. I've tried forcing the BIOS geometry to 2100/16/63 and giving a 'geometry hd0 2100 16 63' to grub, and likewise with 2096/16/63 and 'geometry hd0 2096 16 63', but the result is the same. This is the only drive, and device.map correctly has (hd0) /dev/hda.

What's going on? How can I troubleshoot further? Please Cc: me, I'm not on the list.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]