[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #14056] [PATCH] Adding ability to boot 3rd party's PXE bootcode fro

From: Razvan Vilt
Subject: [bug #14056] [PATCH] Adding ability to boot 3rd party's PXE bootcode from GRUB
Date: Sun, 9 Jul 2006 15:07:37 +0000
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv: Gecko/20060508 Firefox/

Follow-up Comment #3, bug #14056 (project grub):

I've tried to set-up a server that does exactly that (pxeloader
(nd)\startrom.n12), and I always get a TFTP failed error from startrom.n12.
The wierd thing is that it works if I boot startrom.n12 directly (as opposed
to booting through pxegrub).

After that I've tried with another pixie, pxelinux. Although it loads the
pxelinux pixie and it boots corectly, pxelinux does NOT know what the
tftp-server is. That is, there is no TFTP traffic to the server after the
pxelinux load, although the client apparently tries to load pxelinux.cfg/*.
The client also knows the TFTP prefix (as it stated), correctly.

Anyone has any ideas?

It is a RHEL4 AS x86_64 grub that also has all the patches available in the
Sun/OpenSolaris svn, or the ones that I was able to take out of their SVB
(that is diskless and UNDI patches and UNDI fixes from Sun and UFS/VTOC
support). It also has the pxeloader patch from here. And, wierd enough, it
compiles and works ;).


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]