[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub can't read large initrd on flash hdc1

From: Skahan, Vince
Subject: grub can't read large initrd on flash hdc1
Date: Wed, 29 Jun 2005 08:10:22 -0700

I have a ramdisk-based o/s based on a stripped down redhat9
which I built into a initrd image that runs in a 384MB ramdisk.

I've identified the problem down to the point that I can see that
grub is not completing the grub_read( ) of the initrd, if the initrd
is located on (hd0,0) which is hdc1 on this system.  Location in
the sources is stage2/boot.c

The disk is a 2GB Sandisk flash disk, on a PCI Pentium-M
single board computer, although the problem exists when I install
it the same way on multiple models of flash disk, from
multiple manufacturers, as well we trying the flash on different
manufacturer cards.

Seems like there's something about the initrd that grub can't handle,
when it's in certain physical places on the flash. 

Compressed size of the initrd is 138MB or so.  Used to work,
is it possible that something 'in' the initrd is causing the problem ?
I thought grub just tried to determine the location and size of the

Any ideas ?  I'm willing to patch disk_io.c to see exactly where in
grub_read( ) the read isn't completing, or pretty much anything else
needed to figure out how to fix it.

The same image boots fine:
 - on hdc2 or hdc2 on flash
 - on a spinning disk
 - over the network via pxeboot

I've also tried a number of redhat-modified grubs from redhat9,
fc1, fc2, fc3, fc4 as well as a unmodified grub-0.97 from the
original sources.  Same behavior on all.

Reporting here since I can duplicate the problem on unmodified
grub 0.97 - any pointers/help greatly appreciated...

-- address@hidden -- Cabin Network --
             connexion by Boeing sm

reply via email to

[Prev in Thread] Current Thread [Next in Thread]