[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #13044] GRUB changes system ID on partition

From: anonymous
Subject: [bug #13044] GRUB changes system ID on partition
Date: Tue, 10 May 2005 08:01:40 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050426 Firefox/1.0.3


                 Summary: GRUB changes system ID on partition
                 Project: GNU GRUB
            Submitted by: None
            Submitted on: Tue 05/10/2005 at 04:01
                Category: Disk &amp; Partition
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: address@hidden
             Open/Closed: Open
                 Release: 0.96-r1
         Reproducibility: Once
         Planned Release: 



I have not tried reproducing this bug, so hopefully this has happened to
someone else who can add more information on what happened to them. Since I
have not reproduced this bug, I will include everything I did before I

I originally posted my error messages in the Gentoo Forums, so anyone who is
interested can look here:

I had GRUB working wonderfully on my system, until I made a few minor changes
to my grub.conf file. I uncommented the fallback line, and added the lines
hide (hd1,0)
hide (hd1,1)
hide (hd1,2)
to my grub.conf file under the Windows heading. When I rebooted, I got the
following message:
GRUB Loading stage1.5.

GRUB loading, please wait...
Error 17

I used a Knoppix CD to try to diagnose the problem. After changing back my
grub.conf, here's what happened when I ran grub from the command line:
grub> root hd(1,0)
 Filesystem type unknown, partition type 0x93

grub> setup (hd0)
Error 17: cannot mount selected partition

It took me a while to realize that instead of focusing on the line that gave
me the error 17 message, the problem was with the "partition type 0x93"
message, which I had completely overlooked. I ran fdisk, and sure enough my
partition table had been changed. My hard disk had four partitions on it.
Partitions 0-3 had system ID 0x83 and partition 4 had system ID 0x82. None of
the partitions were set bootable. When I looked at my partition table with
fdisk, I saw that the first partition had been set bootable and the first
three partitions had system ID 0x93. I changed the system ID back with fdisk
and now GRUB works fine, and I can boot to my Linux system. Did GRUB do this?
I'm a bit skeptical, myself, because it seems like such a big bug would have
been caught beforehand. Before I rebooted, I also made the first partition
unbootable with fdisk, so it is possible that this is an fdisk bug (I'll send
a message their way, too). Good luck, and hopefully someone can confirm this,
if it truly is a GRUB problem.


Carbon-Copy List:

CC Address                          | Comment
eklitzke --AT-- berkeley --DOT-- edu | Originator Email


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]