[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bugs #12115] Patched grub doesn't boot reiserfs-3.6

From: anonymous
Subject: [bugs #12115] Patched grub doesn't boot reiserfs-3.6
Date: Wed, 23 Feb 2005 14:14:14 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050219 Epiphany/1.5.6


                 Summary: Patched grub doesn't boot reiserfs-3.6
                 Project: GNU GRUB
            Submitted by: None
            Submitted on: Wed 02/23/05 at 14:14
                Category: Booting
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: pharonix
        Originator Email: address@hidden
             Open/Closed: Open
                 Release: CVS-2005-2-23
         Reproducibility: Every Time
         Planned Release: 



Hi all. I've got a question related to reiser4, so it may not be your

It's just that I don't know where else to go. I just compiled CVS grub (
legacy ) with reiser4 and splash patches. 

Patch is attatched here.

Reiser4 and splash both work perfectly, but now grub can boot only from
reiser4 partitions. 

I copied the kernel from my /boot to the reiser4 partition and then used it
to boot.

Everything worked fine. 

However when I rebooted and tried to use the original kernel which is on a
reiserfs (3.6) filesystem, things went weird. grub can read the kernel ( tab
completion works ). 

When I press enter it then complains that " file must be absolute or " bla
bla which means it can't find it. 

On returning to the grub menu, all the menu text is corrupted ( only the menu
entries ) and if I repeat this many times ( by rewriting the boot commands) it
starts showing me text from real files on the reiser filesystem ( scary ).

This is a gentoo system, but I compiled everything by hand without any

gcc (GCC) 3.4.3 20050110

GNU C Library 20041102 release version 2.3.4

Linux Phaeronix 2.6.11-rc1-love1 #4 SMP Fri Feb 18 03:40:35 EET 2005 i686
Pentium III (Coppermine) GenuineIntel GNU/Linux


Carbon-Copy List:

CC Address                          | Comment
pharon --AT-- gmail --DOT-- com     | Originator Email


File Attachments:

Date: Wed 02/23/05 at 14:14  Name: grub-0.96.1-splash-reiser4.patch  Size:
50.73KB   By: None
Reiser4 and splash patches rolled into one.


This item URL is:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]