[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub fails to boot newly installed kernels... works on old ones.

From: Ian Duggan
Subject: Grub fails to boot newly installed kernels... works on old ones.
Date: Thu, 7 Oct 2004 18:46:07 -0700
User-agent: KMail/1.6.2

I'm having a really odd problem with grub.

The history is that I have a server that has gone through some odd gyrartions 
with LVM on RAID1 and such. The Debian Sarge kernels woudln't boot properly 
because they wouldn't start raid properly and LVM would start up using the 
underlying devices instead of the raid onces. Using a second machine, I 
reproduced the problem and verified that using a stock kernel works (rather 
than the debian kernel-image-* packaged versions).

So... I'm trying to get the new kernel installed on the sick server. Using a 
stock kernel and set of libs that I have verified works on an identical box, 
I have tried to get the sick box to boot up. The problem is that though Grub 
properly sees the new kernel and loads it into memory, it doesn't seem to be 
able to kick it off. My boot screen stops with this:

Booting 'Debian GNU/Linux, kernel '

root  (hd0,1)
 Filesystem type is reiserfs, partition type 0xfd
kernel  /vmlinuz- root=/dev/md1 ro console=tty1 console=ttyS0,9600
   [Linux-bzImage, setup=0x1400, size=0x1cf7fb]

Nothing happens after this. Only a power cycle seems to work.

The really odd thing is that kernels on the sick server that have booted 
previously still work just fine. Any new kernel that is installed (including 
Debian kernel-image-* versions) has this problem. Grub doesn't seem to kick 
off the kernel init.

I have tried reinstalling grub and reinstalling the boot sector stuff from the 
grub shell.

Any suggestions on how to debug?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]