[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bugs #10576] 4 hard drives : GRUB can't launch Windows XP

Subject: [bugs #10576] 4 hard drives : GRUB can't launch Windows XP
Date: Mon, 04 Oct 2004 16:10:11 -0400
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

This mail is an automated notification from the bugs tracker
 of the project: GNU GRUB.

[bugs #10576] Full Item Snapshot:

URL: <http://savannah.gnu.org/bugs/?func=detailitem&item_id=10576>
Project: GNU GRUB
Submitted by: Luc VERNEREY
On: Mon 10/04/2004 at 20:02

Category:  None
Severity:  Major
Priority:  5 - Normal
Item Group:  None
Resolution:  None
Privacy:  Public
Assigned to:  None
Originator Name:  Luc VERNEREY
Originator Email:  address@hidden
Status:  Open
Release:  0.94-r1
Reproducibility:  Every Time
Planned Release:  

Summary:  4 hard drives : GRUB can't launch Windows XP

Original Submission:  Hi,

I installed a Gentoo 2004.2 properly, and was able to launch both Windows XP 
and Gentoo from GRUB.
I installed 2 more hard drives, and now it is impossible, but let me give your 
more detail on this stuff.

Config P4 2,6 HT (ABIT i865PE Chipset), no particular raid.
When my config was running cleanly, i had :
1 Seagate Cheetah Ultra Wide SCSI Drive (/dev/sda)
1 SATA Raptor Drive (/dev/sdb)

I setup GRUB on the Cheetah Drive (don't want to have Grub on my Windows MBR 
(but for not any particular reason, in fact)).
To boot Windows, I had the following commands in grub.conf (in the Windows 
loader section) :
map (hd0) (hd1)
map (hd1) (hd0)

Everything was nice.

last week, I added 2 IBM UWide SCSI Drives, so I have now the following config :
scsi id0 : SCSI Cheetah (/dev/sda), grub = hd0
scsi id1 : SCSI IBM #1 (/dev/sdb), grub = hd1
scsi id2 : SCSI IBM #2 (/dev/sdc), grub = hd2
sata drive : Raptor (/dev/sdd), grub = hd3

Note that the two IBM drives are formatted in NTFS for NT4.

So i figured out that i could use the following command to swap my 1st Linux 
drive to my Windows drive, as I was doing when I had only 2 drives.
So I tried the following in grub.conf :
map (hd0) (hd3)
map (hd3) (hd0)

But that doesn't work at all.
I gives me the following message :
"Filesystem type unknown, partition type 0x7", and under this grub message, 
another message, in french this time :
"Fichier du noyau absent sur le disque. Insérez une disquette système, 
redémarrez le système."
Since the message is in French (i'm french Wink ), I think this message is 
written by Windows.
This french message can be translated in : "Missing kernel file on drive. 
Insert a system floppy/disk, reboot the system".

Of course, I could solve this problem by setting up GRUB on my windows drive 
(and set my Windows drive the 1st in the boot order, instead of asking to boot 
the SCSI first), but I would like to understand why I doesn't work.

I, of course, have used the other standard command lines for Grub, to know :

rootnoverify (hd3,0)
chainloader (hd3)+1

I even tried with rootnoverify and root.

It changed nothing.

I tried another way of mapping the disks. Knowing that the Windows XP likes to 
the first to boot, I tried to remap all the disks this way :
map (hd0) (hd3)
map (hd0) (hd1)
map (hd1) (hd2)
map (hd3) (hd0)
I've done that in the hope that keeping the order of the SCSI chain could help 
it work, but it result in the same error message.

I tried also to setup grub again on my SCSI /dev/sda, but nothing changed. 

I read somewhere in the bug reports that all the problems with GRUB and 
multiple devices should be reported.
Feel free to ask more detailled informations (dmesg or something else).

Thanks for any help you could provide.

Luc, France.

P.S : The version installed is the latest stable version available on Gentoo 

For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]