[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub floppy snafu

From: Haines Brown
Subject: Re: grub floppy snafu
Date: Sat, 2 Oct 2004 15:39:49 -0400 (EDT)

> >Then came a econd problem with floppies. When I insert a vfat
> >unmounted floppy and do: 
> >
> >     # cd /usr/lib/grub/i386-pc
> >        # dd if=stage1 of=/dev/fd0 bs=512 count=1
> >        1+0 records in
> >        1+0 records out
> >        # dd if=stage2 of=/dev/fd0 bs=512 seek=1
> >        153+1 records in
> >        153+1 records out
> >
> >The floppy becomes bootable, but is no longer mountable:

> This is very normal
> >I can boot the floppy to the grub> prompt, but being unable to mount
> >it, can't put on it the directories and files needed for a grub
> >menu. If I try the dd to copy stage1 and stage2 after constructing
> >putting in place the directory and files for the menu, doing so
> >destroys the ability to bring up the grub menu.
> >  
> >
> May I with all respect ask you to RTFM ?


Well, I've read the FM a number of times, and did so again carefully
today. It still leaves unanswered questions.

I had apparently become snowed under with a variety of methods for
creating a boot floppy, and managed to mix the installation of the
image on the floppy using dd with directions for creating a menu for
the floppy. 

Info grub describes making a grub boot floppy, and in another section
describes how to set up the menu, not making it clear you can't
combine the two unless the floppy is first created, not by the method it
describes for creating a grub boot floppy, but instead by running
grub> setup. 

This setup command is apparently a script to run the grub install
command, which in turn gave me the impression that it called upon
dd to copy the image file into the floppy boot sector. I wasn't aware
that the grub>setup/install was fundamentally different from copying
the image files with dd. What is the difference?

The install and setup commands for creating a boot floppy look for a
/boot/grub/menu.lst. But no such menu.lst gets generated. I have to
create it by hand. Is that correct? (I do have the file in the
/boot/grub directory of my hd). 

The grub setup command searches for the stage files in /boot/grub, but
apparently won't look for them on my hard disk in that location, but
only on the floppy, where they first must be copied into a proper
directory tree. 

For some reason, when I upgraded from debian woody to sarge (no
hardware changes), grub no longer maps my drives correctly. I can work
around this by using root (hd0,0) for sda, (hd2,0) for sdb, and
(hd1,0) for sdc. I leave the rest of the commands as they are. The
result is a working boot floppy. 

I tried downgrading grub to the woody version by pinning, but that
didn't help

My main question is whether this approach of changing the root command
to point to the wrong disk sequence is likely to cause problems?

I tried fiddling with the map file in /boot without luck, and tried a
map command in the menu, also without luck. 

Haines Brown 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]