[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: URW font download link not valid

From: Dale Snell
Subject: Re: URW font download link not valid
Date: Sun, 11 Aug 2019 11:46:18 -0700

On Sat, Aug 10, 2019 at 2:00 AM Jean Louis <bugs@gnu.support> wrote:
> Hello,
> Sadly, that did not work.
> Can I maybe help the process of building groff, if I can somehow make
> pfb fonts:
> checking whether URW fonts in pfb format are available... no
> So maybe I need to do something to create pfb format?
> Jean
> admin-> ./configure --prefix /package/text/groff 
> --with-urw-fonts-dir=/usr/share/fonts/OTF/
------------------>%============ ker-SNIP! ============%<------------------
> checking whether URW fonts in pfb format are available... no
> checking that generated files are newer than configure... done
> configure: creating ./config.status
> config.status: creating Makefile
> config.status: creating test-groff
> config.status: creating src/include/config.h
> config.status: src/include/config.h is unchanged
> config.status: executing depfiles commands
> GNU Troff version
> ----------------------------------------------------------------------
>  Prefix                          : /package/text/groff
>  Compiler                        : gcc -g -O2
>  X11 support                     : yes
>  X11 resources dir               : /package/text/groff/lib/X11/app-defaults
>  Doc build                       : yes
>  URW fonts for pdf               : no
>  Use uchardet library for preconv: yes
>  pdftools for distcheck          : yes
> ----------------------------------------------------------------------
> configure:
>   The application resource files for gxditview (GXditview and
>   GXditview-color) will be installed in:
>     /package/text/groff/lib/X11/app-defaults
------------------>%============ snip! ============%<------------------
> configure:
>   No URW fonts in .pfb format were found on your system, URW fonts
>   generation for 'devpdf' will not work properly.  These fonts can be
>   downloaded here:
>     http://downloads.ghostscript.com/public/fonts/urw-base35-v1.10.zip
>   By default groff will search these fonts in the paths given by `gs
>   -h' and in these 2 default directories:
>   '/usr/share/fonts/type1/gsfonts/' and
>   '/opt/local/share/fonts/urw-fonts/' (paths used by
>   font/devpdf/Foundry.in).  You can also pass the option
>   '--with-urw-fonts-dir=DIR' to 'configure' to set a custom path.  You
>   would need to re-run the 'configure' script after installing these
>   fonts.

Hoo boy.  This is the same thing that I went through.  I was never
able to get the URW fonts to build correctly.  My final solution
was to ignore the URW fonts completely, and install my own.  Among
the typeface families I installed was TeX Gyre.  These fonts are
look-alike replacements for the URW++ base-35 fonts.  I used Peter
Schaffter's "install-font.sh" script.  It isn't difficult to use, though
it can be a bit tedious if you have a lot of fonts to add.  It's
not necessary to install the source font files into the system;
they can reside in any old directory.  Just make sure that the
files "install-fonts.sh" builds go into the right place.  Since I had built
Groff 1.22.4 from source (Fedora has 1.22.3 in its repos), I put my
new font files in "/usr/local/share/groff/site-font/dev{ps,pdf}".
Since the site-font (and site-tmac) directories are out of the
Groff installation directories, they won't be overwritten when
a new version of Groff is installed.

Now, if you do this, you _may_ wind up with another problem that
I ran into.  When using the fonts that I'd installed myself,
I found that the ASCII apostrophe/single-quote input character was
being output as a standard typewriter apostrophe.  This is
incorrect; it's supposed to be a typographic "curly quote".
I wound up sticking the line

    .tr '\[cq]

in my personal Groff macros file.  This worked, but it bugged me.
I finally stumbled onto a different fix.  Normally, I use pdfmom
to build my PDFs.  When I tried pdfroff, the apostrophe problem
went away.  I've no idea why, but there it is.  I'm not saying
that you'll have this problem.  I still think that I must have done
something wrong when I installed my local fonts.  (The fonts
installed with Groff work fine.)  But in case you do see this problem,
this is what I found to fix it.

Now, all that said, I see that Deri James has just made some changes to
the Groff build programs.  Maybe that will fix the URW installation problem,
and it won't be necessary to install mass quantities of font files.

Anyway, good luck!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]