[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22443: new snapshot available: grep-2.22.33-43f6

From: Zev Weiss
Subject: bug#22443: new snapshot available: grep-2.22.33-43f6
Date: Thu, 4 Feb 2016 03:27:31 -0600
User-agent: Mutt/1.5.24 (2015-08-30)

On Wed, Feb 03, 2016 at 11:07:03PM -0800, Jim Meyering wrote:
On Wed, Feb 3, 2016 at 8:26 PM, sur-behoffski
<address@hidden> wrote:
On 02/03/16 16:37, Jim Meyering wrote:

Part of preparing for a release is to ensure that "make distcheck"
works, and it did not: the post-build "make clean" failed to remove
one of the files the build had created. Fixing that required a
gnulib tweak, which in turn required a grep commit to update
to that latest gnulib commit, so I've made one more snapshot,
just in case. I expect to make the release tomorrow.

grep snapshot:
   http://meyering.net/grep/grep-ss.tar.xz      1.3 MB

Have tried configure/make/make check on:


for an x86_64 Gentoo system:

        - gcc 4.9.3  p1.2;
        - GNU/Linux kernel 4.3.5-gentoo;
        - glibc 2.21-r1;

and there were no errors reported:

Thanks for the testing and report.

I've run the 'make check-expensive' tests on Debian stretch (gcc 5.3.1, glibc 2.21, Linux 4.3) and found no failures. I also tried running them with GCC's ASAN & UBSAN enabled -- tests for grep proper all passed in both cases, though ASAN still reported some memory leaks from the gnulib test suite (I didn't look closely at exactly what they were, but could provide logs if it's of interest).

Zev Weiss

reply via email to

[Prev in Thread] Current Thread [Next in Thread]