[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug#454690: "grep -v" alway returns 0 (was: sl-modem-source: Modules

From: Aníbal Monsalve Salazar
Subject: Re: Bug#454690: "grep -v" alway returns 0 (was: sl-modem-source: Modules don't load)
Date: Sun, 29 Mar 2009 14:59:37 +1100
User-agent: Mutt/1.5.18 (2008-05-17)

retiltle 454690 "grep -v" alway returns 0

On Thu, Dec 13, 2007 at 10:11:41PM +0100, Eduard Bloch wrote:
>reassign 454690 grep
>#include <hallo.h>
>* Eduard Bloch [Thu, Dec 13 2007, 08:41:41PM]:
>>#include <hallo.h>
>>... found it and tried to load...
>>> + grep -v not.found
>>... detected "not found" in the modprobe output...
>Wait a sec, I see the problem. The current "grep -v" apparently always
>returns 0, no matter whether the expression matched something or not.
>It worked with earlier versions though, i.e. non-zero was returned if
>the expression matched at least once (and so some output was
>I will work around the issue in sl-modem-daemon ASAP but it remains a
>problem in grep.
><LGS> Halloechen, ihr Spinner, so frueh auf?
><nusse> nein, wir schlafen alle im kollektiv
><knorke> mein alkoven ist kaputt
><teq> alkohol kaputt?

I can reproduce this bug.

grep -V
GNU grep 2.5.4

echo -e 'hola\nhello' | grep -v hola; echo $?

echo -e 'hola\nhello' | grep -v hallo; echo $?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]