[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grep-2.5.4-20080209b configure infrastructure

From: Tony Abou-Assaleh
Subject: Re: grep-2.5.4-20080209b configure infrastructure
Date: Sun, 17 Feb 2008 03:29:17 -0400 (AST)

On Sun, 10 Feb 2008, Karl Berry wrote:
> I tried compiling the new test release at
> http://alpha.gnu.org/gnu/grep/grep-2.5.4-20080209b.tar.gz with gcc 4.2.3
> on CentOS 5.  configure gave this warning:
> config.status: WARNING:  intl/Makefile.in seems to ignore the --datarootdir 
> setting
> ... which is because gettext has apparently not been updated in a long
> time.  I suggest using the latest official releases of gettext,
> automake, and autoconf.

I spent a few nights already trying to gettextize grep. Learned a lot
about gettextize and gettext in general, but still no go.

Running ./autogen.sh I get the error:

configure.ac:60: error: possibly undefined macro: jm_AC_TYPE_UINTMAX_T
      If this token and others are legitimate, please use
      See the Autoconf documentation.
configure:7686: error: possibly undefined macro: jm_AC_HEADER_INTTYPES_H
configure:7687: error: possibly undefined macro:

Which happens because gettextize changed the definitions in
m4/uintmax_t.m4 from jm_AC_TYPE_UINTMAX_T to gl_AC_TYPE_UINTMAX_T and in
m4/inttypes_h.m4 from jm_AC_HEADER_INTTYPES_H to gl_AC_HEADER_INTTYPES_H.

After gettextize, jm_AC_TYPE_UINTMAX_T was still required by
configure.ac.in and jm_AC_HEADER_INTTYPES_H by m4/xstrtoumax.m4.

I could manually rename these two jm_'s to gl_'s but I'm not sure if
that's a good solution. Looking at GNU Hello, it appears the problem was
eliminated by using gnulib and removing m4 from CVS.

Current grep CVS includes intl/, but GNU Hello doesn't. Is it a good idea
for grep to follow path and remove intl/ and m4/ like hello did?



Tony Abou-Assaleh
Email:    address@hidden
Web site: http://tony.abou-assaleh.net

reply via email to

[Prev in Thread] Current Thread [Next in Thread]