[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnupod] GNUpod - mktunes.pl fails with "Failed to create spldatamho

From: Eddie Marrett
Subject: [Bug-gnupod] GNUpod - mktunes.pl fails with "Failed to create spldatamhod"
Date: Tue, 8 Jul 2008 13:41:17 +0100


I've started trying to use GNUpod with my iPod all has worked
perfectly until I try updating the iTunesDB with mktunes.pl. Then the
following happens:

$ mktunes -m /media/usb0
mktunes 0.99.6-CVS (C) Adrian Ulrich
> Loading ArtworkDB...done
> Parsing XML document...
> 4098 files parsed, assembling iTunesDB...
> Creating iPod playlists...
>> Created Smart-Playlist '90's Music' with 1296 files
Failed to create spldatamhod

The iPod I'm using is an 80Gb generation 6 iPod Classic (so has the
new hashing thing/firewire serial ID in it's database). The iPod has
in the past been loaded up with tunes using GTKPod and it's associated
libgpod (version 6+) library. I've tried passing this the mktunes
manually but it makes no difference.

Running mktunes though the perl debugger it actually dies on line 236
of Mktunes.pm:
$buff_playlist .=
,data=>$self->GetSmartPlaylist($name)}) || die "Failed to create

Though I have no idea what mk_spldatamhod actually does or where it's
stored on my system, so my own problem solving hit a brick wall.

Any ideas? (or if you need any more information about my setup let me know).

Many thanks

reply via email to

[Prev in Thread] Current Thread [Next in Thread]