[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Gnubg on MacOS High Sierra

From: Michael Petch
Subject: Re: [Bug-gnubg] Gnubg on MacOS High Sierra
Date: Fri, 22 Dec 2017 19:59:53 -0700
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0

On 2017-12-22 17:47, Marcell Fulop wrote:
> Did you do that with XCode? Can you share details of the this build please?

Reading your response tells me a couple of things that we have done
differently. You used Homebrew (which I believe doesn't use quartz
windows manager as a gtk+2 backend (at least by default). I used
Macports. Actually the reason I use Macports was it was the only way to
really make a standalone DMG that could contain GNUBG installations.

With that being said I followed the typical installation guidelines on
macports.org. I did this on a virgin macOS High Sierra install, with the
exception that I installed the xquartz X11 interface from www.xquartz.org).

I didn't need a complete copy of Xcode (just the Xcode command line
tools which the instruction guide you on doing).

Once Macports itself was installed I installed the Macports version of
GNUBG (which is at 1.05.002) with the command:

sudo port install gnubg +board3d +x11 +random_org

This enables X11 and 3d Boards and dice generation from random org.

Once it was built up it ran great using X11 (although I think there is a
long standing bug that may make GNUbg appear to hang when sound is enabled).

I then installed macports CVS, pulled out the latest cvs code and did a
build. I will have to dig up the exact command line I used (I had to
build it without Python support since I originally didn't have time to
hunt down the header issue a couple days ago that gave the Python code
some headaches). The latest build with X11 enabled worked fine.

If we back up a bit, what also surprised me was this. On MacOS High
Sierra (I have never use MacOS), the first thing I actually did was
install www.xquartz.org (xquartz is the quartz interface with an X11
backend) and installed the gnubg 1.04.000 DMG for 10.10 from the
wesbite. I did this to see what errors were produced. Interestingly
enough that old DMG worked the way it had under 10.10.The first time it
is run you need to give it a few minutes to load (if on a slower Mac)
which is documented in the readme file in the DMG.

When run occasionally the GNUBG window might come up white with borders.
This is easy to resolve. Just resize the window a bit and it will render
as expected.

I have never used MacOS Sierra (the previous release). Maybe it didn't
work on that release, but it does seem to work on High Sierra as it did
on versions 10.10 and earlier.It surprised me that it runs because over
the past couple of years I assumed it didn't based on all the posts
about it. So it was a surprise to me when it worked. including board3d

reply via email to

[Prev in Thread] Current Thread [Next in Thread]