[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] compiling on linux

From: Anders Persson
Subject: Re: [Bug-gnubg] compiling on linux
Date: Mon, 24 Apr 2017 18:09:53 +0200


It was 1.05.000 so I tried to compile 1.05.002 instead now. It told me I was lacking python, gtk and gtkglext. After installing these, it worked! The game lacked sound though but I fixed that by typing "play" in the settings/sound command.

And... the compiled program is just as fast as the windows version! :-)

Thank you very much for your help!

Kind Regards,
Anders Persson

2017-04-23 21:55 GMT+02:00 Philippe Michel <address@hidden>:
On Thu, 13 Apr 2017, Anders Persson wrote:

Ok, so here is another question/issue:

I'm trying to compile gnugb on Linux Mint.

./configure --prefix=/home/anders/program/gnubg
make install

Everything looks fine and no error messages. But when trying to run gnugb
in a terminal, nothing happens. It hangs and uses 100% cpu on one core.
It's possible to break it with Ctrl-C.

My system: Linux Mint 18.1 xfce 64 bit running on an AMD Athlon 5600+ dual

What version of the gnubg sources do you use ? Mint's source package ?

Your description looks very much like what was discussed in this thread :
and apparently Mint 18 include gnubg 1.05.000 anf gcc5, a combination affected by the above issue.

Among the tar files at http://files.gnubg.org/media/sources/ , only the most recent one, 1.05.002  has this problem fixed. Pulling the current development head as described here at http://www.gnubg.org/index.php?itemid=26
should work as well.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]