[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Gthreads under Win

From: Michael Petch
Subject: Re: [Bug-gnubg] Gthreads under Win
Date: Mon, 22 Jun 2009 16:08:11 -0600
User-agent: Microsoft-Entourage/

Most bugs I can reproduce except this gthreads one. Using the –gmt build from about 10 days ago that was put on the site, I have had no issues with it. I can change eval threads no problem. No crash on close down either (I have tried 2d and 3d, even played with the animated close board sequence at shutdown. That GMT version has worked very well for me. Either a) there is an environmental difference (windows/hardware) b) my Gnubg settings are different enough to mask the problems. I have tried on 4ply checker and 2 ply cube – and no issues either.

I believe it was reported that if I launch the GMT version and then hit the X in the upper right to close the app, that it should crash very easily. I can’t reproduce it! I also know that I am running the right one. Depwalker does show gthreads being loaded with that release.

If you want to sift through my depwalker data(just in case), here it is:


On 22/06/09 3:50 PM, "Jonathan Kinsey" <address@hidden> wrote:

I've had a try with gthreads and windows and it seems to crash when I change the
number of threads (also when shutting down in the same code).  I'll try and fix it.

Slightly better news, the performance seems fine so when this is fixed we should
be able to remove the windows threading code.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]