[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnubg] compiling gnubg under msys

From: Wheeler, Dr M.D.
Subject: [Bug-gnubg] compiling gnubg under msys
Date: Tue, 5 Jul 2005 11:27:02 +0100

Dear All,
I am trying to compile gnubg under MSYS on a win2k machine.
I have the following setup
MSYS-1.0.10 along  with the developer toolkit msysDTK-1.0.1
for GTK i am using the version included in glade
in my msys environment I have set up a mount point in fstab
c:/gtk    /target
using this I can compile a helloworld.c application in gtk examples
I am now trying to compile gnubg, to start off with I am going to keep it 
simple and not include python so I run the following:
followed by,
env CC="gcc -mms-bitfields -mno-cygwin" ./configure --without-guile 
--without-gdbm --without-board3d --without-sound --without-python
I get the following warnings
checking for gtkextra-2.0... Package gtkextra-2.0 was not found in the 
pkg-config search path.
Perhaps you should add the directory containing `gtkextra-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkextra-2.0' found
checking for libart-config... no
checking for LIBART - version >= 0.2.5... no
*** The libart-config script installed by LIBART could not be found
*** If LIBART was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the LIBART_CONFIG environment variable to the
*** full path to libart-config.

which I think I can safely ignore for now.
when I run make everything chugs along until
Making all in doc
make[2]: Entering directory `/d/home/Projects/gnubg/doc'
cd . \
  && /bin/sh /d/home/Projects/gnubg/missing --run makeinfo   \
       `echo gnubg.texi | sed 's,.*/,,'`
' in @synindex.nknown index `vr' and/or `cp
makeinfo: Removing output file `/d/home/Projects/gnubg/doc/gnubg.info' due to 
errors; use --force to preserve.
make[2]: *** [gnubg.info] Error 1
make[2]: Leaving directory `/d/home/Projects/gnubg/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/d/home/Projects/gnubg'
make: *** [all] Error 2
anyone have any ideas what this is about??

reply via email to

[Prev in Thread] Current Thread [Next in Thread]