[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-gnuastro] Error installing gnuastro 0.8

From: Alejandro Serrano Borlaff
Subject: [bug-gnuastro] Error installing gnuastro 0.8
Date: Tue, 9 Apr 2019 18:14:44 +0200

Dear all,

I am trying to install Gnuastro in a Ubuntu 18.10 machine. I successfully installed wcslib, cfitsio, and gsl, but after ./configure in gnuastro, when I run make -j8  I got the following error (same result on 0.8, 0.7, and .

/lhome/aserrano/Downloads/gnuastro-0.8.36-9e13/lib/.libs/libgnuastro.so: undefined reference to `gsl_interp_steffen'
collect2: error: ld returned 1 exit status
Makefile:1789: recipe for target 'astarithmetic' failed
make[2]: *** [astarithmetic] Error 1
make[2]: Leaving directory '/lhome/aserrano/Downloads/gnuastro-0.8.36-9e13/bin/arithmetic'
Makefile:1895: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/lhome/aserrano/Downloads/gnuastro-0.8.36-9e13'
Makefile:1785: recipe for target 'all' failed
make: *** [all] Error 2

I tried with gsl 2.5 and 2.4, with the same result, and in Ubuntu 16.04 (I updated my machine in order to get rid of the error) but there was no luck.

I attach the full log for more information. Thanks a lot.

Attachment: log.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]