[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#43389: 28.0.50; Emacs memory leaks using hard disk all time

From: Jean Louis
Subject: bug#43389: 28.0.50; Emacs memory leaks using hard disk all time
Date: Fri, 27 Nov 2020 11:44:33 +0300
User-agent: Mutt/2.0 (3d08634) (2020-11-07)

* Carlos O'Donell <carlos@redhat.com> [2020-11-27 07:54]:
> Each process generates a trace, and that trace contains the data for
> all threads in the process.
> I've just pushed MTRACE_CTL_CHILDREN, set that to 0 and the children
> will not trace. Thanks for the feedback and enhancement.

Thank you, that is nice feature, I will use it for the next session.

I have finished one trace and now packing it to see if it can be packed and 

I will upload it and share the hyperlink to Carlos and Eli as private email.

Sadly I could not invoke my function M-x good-bye and I also did not
see this time problem with swapping. Problem came that I have invoked
M-x eww and was browsing and it blocked. I had to interrupt. But
nothing worked in the end and user interface became not responsive. I
could not type a key, use mouse or do anything. Hard disk was working,
not much, and not that the LED was turned on as usual continually.

I have been doing usual work, nothing special. Just using eww. Mouse
and menu did not work. M-x did not work. Interrupting with ESC man
times or C-g did not work. It worked once to get error in process
filter but after everything was blocked.

My vsize function have been showing me over 4 GB vsize value in
minibuffer. Swap size was under 200 MB this time. 

When the condition occurs that we are trying to capture my swap size
was always 2-3 GB minimum, and I have 4 GB RAM.

I had to invoke xkill to kill Emacs. Hyperlink with mtrace is coming
as soon as it hopefully gets packed better. 

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]