bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#39489: 28.0.50; On Emacs 27, 28, tramp hangs indefinitely


From: Michael Albinus
Subject: bug#39489: 28.0.50; On Emacs 27, 28, tramp hangs indefinitely
Date: Fri, 07 Feb 2020 22:34:13 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Benjamin Slade <address@hidden> writes:

Hi Benjamin,

> * On Emacs 27 & 28, tramp hangs indefinitely
> - So if I try something like =C-x C-f /sudo::/etc/rc.conf= , tramp
>   simply hangs until I press =C-g=.
> - This is true with my normal configuration with the latest of
>   Emacs 27 or 28, and also if I run with =emacs -q=. It does work,
>   asking me for my password, if I run with =emacs -Q=.
>   =emacs -q= or with my normal configuration.
> - I've had tramp issues with the development version of Emacs for
>   at least the past year, but figured it was likely something in
>   my =init.el= which was the issue. (Up until recently, I was able
>   to partially work around the issue by keeping my system password
>   in ~/.authinfo.gpg and getting something other than tramp to
>   trigger unlocking of .authinfo.gpg.)
> - on the latest development version/version 28 of Emacs, with
>   =(setq tramp-verbose 10)=, I get the following *tramp debug*
>   log:

According to the traces, it is still a problem with the password:

> 09:43:31.208362 tramp-accept-process-output (1) # Quit: "Quit", ""
> Sorry, try again.
> Password:

You say, that "emacs -Q" is working for you. Could you please bisect
your init file, until you find the culprit config? The smallest one? And
could you pls show your guilty config then? I don't need the text of any
configured password, but how it is provided by auth-source.

Best regards, Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]