bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#38918: 26.3; EBDB fails to edit (add) tags


From: Jorge P . de Morais Neto
Subject: bug#38918: 26.3; EBDB fails to edit (add) tags
Date: Sat, 04 Jan 2020 21:02:16 -0300

Error inserting field: cl-no-applicable-method, (ebdb-record-delete-field 
#s(ebdb-record-person #s(ebdb-field-uuid ce30c771-c0e3-4874-ab90-a8e49078e531) 
#s(ebdb-field-creation-date (24078 20399 443853 624000)) 
#s(ebdb-field-timestamp (24081 9450 666073 294000)) (#s(ebdb-field-tags 
(TODO))) nil nil t #s(ebdb-cache John Doe (John Doe Doe, John) (ACME) nil 
(address@hidden) doe, john (#s(ebdb-db-file ~/.emacs.d/ebdb File: ebdb 
#s(ebdb-field-uuid 41310d36-e033-4b31-81fa-c1c9421c8cb7) (24081 9445 487995 
717000) (#1 #s(ebdb-record-organization #s(ebdb-field-uuid 
88bf0c5e-6c6c-4317-899a-8cf19dd4c6a5) #s(ebdb-field-creation-date (24078 20310 
981426 250000)) #s(ebdb-field-timestamp (24078 20310 981328 143000)) nil nil 
nil nil #s(ebdb-cache ACME nil nil nil nil acme (#4)) nil nil nil 
#s(ebdb-field-name-simple ACME) #s(ebdb-field-domain acme.com))) nil 0.1  nil t 
t nil ebdb-record-person))) nil nil nil #s(ebdb-field-name-complex Doe (John) 
nil nil nil) nil nil (#s(ebdb-field-role CEO 
ce30c771-c0e3-4874-ab90-a8e49078e531 88bf0c5e-6c6c-4317-899a-8cf19dd4c6a5 
#s(ebdb-field-mail nil address@hidden primary) nil nil))) (#s(ebdb-field-tags 
(TODO))))
Em [2020-01-04 sáb 10:55:41-0800], Eric Abrahamsen escreveu:

> Would you please eval the following forms and let me know if everything
> works as expected?
> [...]

Thank you for the fix.  With it I can indeed insert a tag.  I tested on
my real EBDB database on Spacemacs develop as well as on the pure GNU
Emacs with minimal customization and minimal EBDB database I used to
reproduce this bug.  The tests were quick however, I just added a small
tag to a few records, and on one case I edited a tags field to add a
second tag (manually separated by ":").

There are still quirks:

1. When hitting "i" to insert a tags field on a record that already has
   a tags field, I get a big error message (attached).  I would prefer a
   short and clear error message.
2. When editing a tags field with the extended interface ("E"), and
   adding a second tag, I can successfully hit "[Apply]" and it works;
   but when hitting "[Accept]" I get an error.

Regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]