bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37042: 27.0.50; configure --without-all doesn't work on macOS


From: Alan Third
Subject: bug#37042: 27.0.50; configure --without-all doesn't work on macOS
Date: Wed, 01 Jan 2020 11:46:50 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (darwin)

Philipp <address@hidden> writes:

> configure: error: Non-toolkit scroll bars are not implemented for Nextstep.
>
>
> It's trivial to work around this (pass --with-toolkit-scroll-bars), but
> it would be nice if the workaround weren't necessary.

Perhaps we should just warn instead of erroring.

>From dee6bcdaa94fe4044278793357f45d855fb8c79c Mon Sep 17 00:00:00 2001
From: Alan Third <address@hidden>
Date: Wed, 1 Jan 2020 11:44:21 +0000
Subject: [PATCH] * configure.ac (HAVE_NS): Don't error on non-toolkit
 scrollbars.

---
 configure.ac | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 1c3fe7853e..ea448681d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2050,7 +2050,7 @@ AC_DEFUN
 NS_OBJC_OBJ=
 if test "${HAVE_NS}" = yes; then
   if test "$with_toolkit_scroll_bars" = "no"; then
-    AC_MSG_ERROR([Non-toolkit scroll bars are not implemented for Nextstep.])
+    AC_MSG_WARN([Non-toolkit scroll bars are not implemented for Nextstep.])
   fi
 
   window_system=nextstep
-- 
2.24.0

-- 
Alan Third

reply via email to

[Prev in Thread] Current Thread [Next in Thread]