bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#36725: 26.1; Emacs can't connect to gnu elpa


From: Noam Postavsky
Subject: bug#36725: 26.1; Emacs can't connect to gnu elpa
Date: Fri, 19 Jul 2019 08:14:32 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.2.90 (gnu/linux)

Tim Cross <address@hidden> writes:

> Yep, checked and it made no difference. Did get a little more wrt error info
>
> gnutls.el: (err=[-50] The request is invalid.) boot: (:priority
> "NORMAL:-VERS-TLS1.3" :hostname melpa.org :loglevel 0 :min-prime-bits 256
> :trustfiles (/etc/ssl/certs/ca-certificates.crt) :crlfiles nil :keylist nil
> :verify-flags nil :verify-error nil :callbacks nil)

Oh, what is your value of libgnutls-version?  Perhaps it's not new
enough to recognize the TLS1.3 thing.  Now I'm wondering if the problem
is intermittent, and previous reports of that workaround helping are
just coincidence.

> Also tried with TLS 1.2, same error.

You mean you tried (setq gnutls-algorithm-priority
"NORMAL:-VERS-TLS1.2")?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]