bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#32469: 26.1; windows 10 emacs doesn't draw *some* pngs correctly


From: james
Subject: bug#32469: 26.1; windows 10 emacs doesn't draw *some* pngs correctly
Date: Sun, 14 Jul 2019 20:40:13 -0700

It’ll take me a while to check for this.

> On Jul 12, 2019, at 7:52 PM, Lars Ingebrigtsen <address@hidden> wrote:
> 
> James Nguyen <address@hidden> writes:
> 
>> https://github.com/jojojames/emacs-windows-png-repro
>> 
>> Added some screenshots here^
>> 
>> Pngs created using imagemagick from svg files do not display correctly
>> in Emacs (they do not display transparency correctly). In the linked
>> repro, the images are surrounded with a yellow/orange instead of 
>> transparency.
>> 
>> The images display with transparency in other Windows programs I
>> tried. (Web browser, File browser, default image viewer in Windows.)
>> These images also display correctly on OSX (and its various
>> applications, including Emacs).
>> 
>> After playing around with the imagemagick setting, it seems prefixing
>> PNG32: to the output file makes the image compatible with Windows Emacs.
> 
> The image handling has been reworked substantially over the last few
> months -- are you still seeing this on the Emacs trunk?
> 
>> In GNU Emacs 27.0.50 (build 1, x86_64-w64-mingw32)
>> of 2018-05-03 built on CIRROCUMULUS
> 
> -- 
> (domestic pets only, the antidote for overdose, milk.)
>   bloggy blog: http://lars.ingebrigtsen.no






reply via email to

[Prev in Thread] Current Thread [Next in Thread]