bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#36523: 26.1; Image files are sometimes not found


From: Eli Zaretskii
Subject: bug#36523: 26.1; Image files are sometimes not found
Date: Sat, 06 Jul 2019 15:33:38 +0300

> From: Markus Triska <address@hidden>
> Date: Sat, 06 Jul 2019 14:16:03 +0200
> 
> 
> Also, the info manual states in 39.17.2 Image Descriptors:
> 
>    ‘:file FILE’
>         This says to load the image from file FILE.  If FILE is not an
>         absolute file name, it is expanded in ‘data-directory’.
> 
> Hence, I expect the following form to insert right.xpm, which is located
> in images/custom/right.xpm relative to data-directory:
> 
>    (insert-image '(image :type xpm
>                          :file "images/custom/right.xpm"
>                          :ascent center))
> 
> However, when I evaluate the form with C-x C-e, I see a blank rectangle
> at the end of the form instead of the intended image.
> 
> In contrast, changing the form to:
> 
>    (insert-image '(image :type xpm
>                          :file "custom/right.xpm"
>                          :ascent center))
> 
> inserts the intended image. Please note that "images/" had to be dropped
> from the path, even though it belongs to the path of the file.
> 
> Could you please consider changing the documentation or implementation
> to match the observed behaviour?

Fixed, thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]