[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30672: 26.0.91, Font face lost ?

From: Fabrice Popineau
Subject: bug#30672: 26.0.91, Font face lost ?
Date: Fri, 2 Mar 2018 11:29:11 +0100

2018-03-02 9:53 GMT+01:00 Eli Zaretskii <address@hidden>:
> From: Fabrice Popineau <address@hidden>
> Date: Thu, 1 Mar 2018 21:40:14 +0100
> I don't have a standalone way to reproduce the problem but the following
> is quite easy if you have the all-the-icons and memoize packages installed.
> Start with 'emacs -Q' and from the *scratch* buffer.
> (require 'memoize)
> (require 'all-the-icons)
> (all-the-icons-insert-alltheicon)
> At this point, a list of icons is offered from the "all-the-icons.ttf"
>  font. The glyph is correct. Select anyone of these glyphs and when it
>  is inserted in the *scratch* buffer, the font face is lost and you get
>  an empty glyph.

Could be related to yank-excluded-properties, perhaps?  Or maybe you
need to tweak yank-handled-properties?

Thanks for the tip ...
If the above doesn't give a clue,

but it didn't. Tried to set yank-excluded-properties to nil with no result.
then please explain what you mean by
"the font face is lost".

(I cannot afford repeating your recipe, because it requires installing
weird fonts on my system.  Sorry.)

I attach 2 screen captures to show the problem. 

First image is the glyph selection and second image shows that the font has been lost
somehow ("no font available").

I hope it is not related to my own build with mingw64 but it has definitely worked with 
some previous version of the same emacs-26 branch. Without any other clue,
I'll try to rewind the branch and see if I can track some related change.


Attachment: 2018-03-02 11_09_35-emacs@MARVIN.png
Description: PNG image

Attachment: 2018-03-02 11_10_21-Re_ bug#30672_ 26.0.91, Font face lost _ - fabrice.popineau@gmail.com - Gmail.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]