bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23561: epg tests are (almost) always skipped


From: npostavs
Subject: bug#23561: epg tests are (almost) always skipped
Date: Sun, 23 Jul 2017 01:02:09 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.2.50 (gnu/linux)

address@hidden writes:

> Yes, the only difference left between this and the package-tests is the
> 'no-cache' argument, though I haven't quite worked out how the cache
> gets filled for package-tests in the first place.

package-test-signed calls (epg-check-configuration (epg-configuration)),
the obsolete `epg-configuration' functions fills the cache without
checking the version, and epg-check-configuration only checks against
epg-gpg-minimum-version which is "1.4.3", hence 2.0.x can satisfy it.

Then when (epg-find-configuration 'OpenPGP) is called, the cache already
has the 2.0 config in it, and so just uses that instead of rejecting
"gpg2" for being less than 2.1.6.

[1: e80c2a7b47] says that "Emacs doesn't work well with 2.0 series".
But if I understand correctly, Glenn is now seeing all the tests pass
using 2.0.22 (cf [2: 24d06313c4]), so...

[1: e80c2a7b47]: 2016-02-17 16:47:24 +0900
  Make GnuPG version check robuster
  
http://git.savannah.gnu.org/cgit/emacs.git/commit/?id=e80c2a7b47d161f00aac096b9d58a18879a122e8

[2: 24d06313c4]: 2017-05-15 21:01:30 -0400
  Stop some epg tests failing on rhel7 with gpg 2.0.22 (bug#23619)
  
http://git.savannah.gnu.org/cgit/emacs.git/commit/?id=24d06313c4f205061fb74c9665d5819a05362636





reply via email to

[Prev in Thread] Current Thread [Next in Thread]