[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#27516: 25.2.50; Building master branch on MSW fails because of gnutl

From: Noam Postavsky
Subject: bug#27516: 25.2.50; Building master branch on MSW fails because of gnutls and other reasons...
Date: Wed, 28 Jun 2017 10:09:46 -0400

On Wed, Jun 28, 2017 at 7:31 AM, Vincent Belaïche
<address@hidden> wrote:
> When trying to build the latest on master branch, I get this error:
> --8<----8<----8<----8<----8<-- begin -->8---->8---->8---->8---->8----
> configure: error: The following required libraries were not found:
>      gnutls
> Maybe some development libraries/packages are missing?
> If you don't want to link with them give
>      --with-gnutls=no
> as options to configure
> --8<----8<----8<----8<----8<--  end  -->8---->8---->8---->8---->8----
> I am using configure with the following command line:
> --8<----8<----8<----8<----8<-- begin -->8---->8---->8---->8---->8----
>   ./configure --prefix=c:/Nos_Programmes/GNU/Emacs \
>                           --without-jpeg \
>                           --without-tiff \
>                           --without-gif \
>                           --without-png \
>                           --with-gnutls=no
> --8<----8<----8<----8<----8<--  end  -->8---->8---->8---->8---->8----

> So I am surprised. Also without `--with-gnutls=no' I get the same error
> message, although I have put under my mingw directory the gnutls binary
> from sourceforge EZWinPorts, but configure does not detect its presence.

./configure uses pkg-config to test for gnutls, so you need to have
pkg-config as well as the gnutls.pc file in the pkg-config
PKG_CONFIG_PATH. Try running

   pkg-config --debug gnutls

> Having or not --with-gnutls=no does not change the outcome as far as
> error message is concerned. I am a bit confused because in the configure
> --help, `--without-gnutls' is mentioned instead of `--with-gnutls=no'. I
> tried `--without-gnutls' and the compilation went through. So this is an 
> error in the message given by configure.

Using --with-gnutls=no works for me, is it possible you have some
extra whitespace after one of the backslashes?

> Well, when I am writing the the compilation went through, this is not up
> to the end, because I got this later on:
> --8<----8<----8<----8<----8<-- begin -->8---->8---->8---->8---->8----
> Loading 
> c:/Programmes/installation/emacs-install/master/emacs/lisp/emacs-lisp/eldoc.el
>  (source)...
> dumped_data_commit: memory exhausted.
> Enlarge dumped_data[]!
> mv -f emacs.exe bootstrap-emacs.exe
> mv: cannot stat `emacs.exe': No such file or directory
> make[2]: *** [bootstrap-emacs.exe] Error 1
> --8<----8<----8<----8<----8<--  end  -->8---->8---->8---->8---->8----

Hmm, doesn't happen for me, but you can try enlarging DUMPED_HEAP_SIZE
in src/w32heap.c

reply via email to

[Prev in Thread] Current Thread [Next in Thread]