bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#26299: 24.5; Use of `…' in Info


From: Noam Postavsky
Subject: bug#26299: 24.5; Use of `…' in Info
Date: Thu, 30 Mar 2017 10:34:36 -0400

On Thu, Mar 30, 2017 at 9:49 AM, Drew Adams <address@hidden> wrote:
>
> Maybe Emacs needs to work around the problem (if it can't be
> fixed).  Maybe if Emacs uses `. . .' instead of `...' that
> will stop Texinfo from messing with it.
>
> (Why would Texinfo have a blanket treatment of ... as …?
> That makes no sense at all.  What if the occurrence of ...
> is part of code, and NEEDS to be 3 period chars?)

Emacs' .texi files use @dots{} in these cases, as (strongly)
recommended by the texinfo manual:

https://www.gnu.org/software/texinfo/manual/texinfo/html_node/_0040dots.html

    An ellipsis (a sequence of dots) would be spaced wrong when typeset as
    a string of periods, so a special command is used in Texinfo: use the
    @dots{} command to generate a normal ellipsis, which is three dots in
    a row, appropriately spaced … like so. To emphasize: do not simply
    write three periods in the input file; that would work for the Info
    file output, but would produce the wrong amount of space between the
    periods in the printed manual.

I found this thread [1] requesting plain "..." for @dots{} in makeinfo
output; there seemed to be no opposition, but I guess it didn't
happen. Perhaps try pinging address@hidden

[1]: https://lists.gnu.org/archive/html/bug-texinfo/2015-07/msg00013.html





reply via email to

[Prev in Thread] Current Thread [Next in Thread]