bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#26229: 26.0.50; shell-mode: turning off input echoing


From: John Mastro
Subject: bug#26229: 26.0.50; shell-mode: turning off input echoing
Date: Fri, 24 Mar 2017 10:49:05 -0700

Hi Manuel,

Manuel Uberti <address@hidden> wrote:
> thanks for the quick reply. I'm afraid your solution doesn't fix
> the problem for me. Could it depend on the shell I'm using? I'm using
> the Fish shell.

I haven't used fish before but I don't think it should be a problem.

I tried to reproduce the problem in Emacs 26.0.50 (commit 211d41a) with
fish 2.3.1 on Fedora 25 but it worked correctly for me.

I started emacs with "emacs -Q", then pasted the following into the
*scratch* buffer and evaluated it:

    (setq explicit-shell-file-name (executable-find "fish"))

    (defun my-init-shell-mode ()
      (setq comint-process-echoes t))

    (with-eval-after-load 'shell
      (add-hook 'shell-mode-hook #'my-init-shell-mode))

I then invoked `M-x shell', confirmed I was using fish, and typed a few
commands, none of which echoed the command.

Just to be sure, perhaps it's worth trying again, and confirm that the
value of `comint-process-echoes' is t in the shell buffer? You can check
it's value by invoking `M-: comint-process-echoes RET' while the shell
buffer is current.

        John





reply via email to

[Prev in Thread] Current Thread [Next in Thread]