bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#26090: 26.0.50; Documentation for epg-gpg-program not sufficient


From: Jens Lechtenboerger
Subject: bug#26090: 26.0.50; Documentation for epg-gpg-program not sufficient
Date: Mon, 13 Mar 2017 20:20:35 +0100

Hi there,

this is a followup to https://debbugs.gnu.org/24229 and
https://debbugs.gnu.org/25947 .

If epg-gpg-program has the default value "gpg2" and if gpg2's version is
2.0.x, then gpg 1.x will be used (if it is installed).

The attached patch extends the doc string of epg-gpg-program to explain
that epg-gpg-program needs to be customized to "gpg2" then (as hinted at
in https://debbugs.gnu.org/24229).

I fail to see that this is a reasonable behavior (why initialize that
variable to gpg2 in the first place although that value will be
ignored?), but at least it needs to be documented.

Best wishes
Jens

>From bcd4239ea9472dcbb9922808d3a2ce832c381a71 Mon Sep 17 00:00:00 2001
From: Jens Lechtenboerger <address@hidden>
Date: Mon, 13 Mar 2017 19:58:51 +0100
Subject: [PATCH] Add more details to doc string of epg-gpg-program

* lisp/epg-config.el (epg-gpg-program): Augment doc string.

If epg-gpg-program has the value "gpg2", "gpg" may be used instead.
Use of gpg2 can be enforced via customize then.  This was explained in
(Bug#24229) and referenced in (Bug#25947).
---
 lisp/epg-config.el | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/lisp/epg-config.el b/lisp/epg-config.el
index 7b963ad..04e4596 100644
--- a/lisp/epg-config.el
+++ b/lisp/epg-config.el
@@ -46,7 +46,14 @@ epg-gpg-program
                              "gpg")
   "The `gpg' executable.
 Setting this variable directly does not take effect;
-instead use \\[customize] (see the info node `Easy Customization')."
+instead use \\[customize] (see the info node `Easy Customization').
+
+Note that if this variable has the default value \"gpg2\" and
+if your version of gpg is 2.0.x (instead of the modern variant
+2.1.x), then gpg 1.x will be used (if it is installed) regardless
+of this variable.  If you really want to use gpg2 version 2.0.x,
+you need to \\[customize] this variable to \"gpg2\" (even if that
+is its default value)."
   :version "25.1"
   :group 'epg
   :type 'string)
-- 
2.7.4


reply via email to

[Prev in Thread] Current Thread [Next in Thread]