bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25241: Emacs 25.1.90 pretest crash on macOS 10.10 Yosemite


From: Alan Third
Subject: bug#25241: Emacs 25.1.90 pretest crash on macOS 10.10 Yosemite
Date: Wed, 08 Mar 2017 13:42:45 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (darwin)

Eli Zaretskii <address@hidden> writes:

>> From: Alexis Layton <address@hidden>
>> Date: Wed, 21 Dec 2016 15:27:30 -0500
>> Cc: Alexis Layton <address@hidden>,
>>  address@hidden
>> 
>>  It would help if you could run Emacs under a debugger and show
>>  backtrace when it crashes.
>> 
>>  Thanks.
>> 
>> Sadly this is not as informative as it looks:
>> 
>> $ lldb /Applications/Emacs.app/Contents/MacOS/Emacs-x86_64-10_9 
>> (lldb) target create 
>> "/Applications/Emacs.app/Contents/MacOS/Emacs-x86_64-10_9"
>> Current executable set to 
>> '/Applications/Emacs.app/Contents/MacOS/Emacs-x86_64-10_9' (x86_64).
>> (lldb) r
>> Process 23181 launched: 
>> '/Applications/Emacs.app/Contents/MacOS/Emacs-x86_64-10_9' (x86_64)
>> Process 23181 stopped
>> * thread #1: tid = 0x1550e6, 0x000000010084979d 
>> libnettle.6.dylib`nettle_sha256_init + 4, queue =
>> 'com.apple.main-thread', stop reason = EXC_BAD_INSTRUCTION 
>> (code=EXC_I386_INVOP, subcode=0x0)
>> frame #0: 0x000000010084979d libnettle.6.dylib`nettle_sha256_init + 4
>> libnettle.6.dylib`nettle_sha256_init:
>> -> 0x10084979d <+4>: vmovaps 0x130bb(%rip), %xmm0 ; nettle_sha256_init.H0 + 
>> 16
>> 0x1008497a5 <+12>: vmovups %xmm0, 0x10(%rdi)
>> 0x1008497aa <+17>: vmovaps 0x1309e(%rip), %xmm0 ; nettle_sha256_init.H0
>> 0x1008497b2 <+25>: vmovups %xmm0, (%rdi)
>
> This looks like the crash is inside libnettle, a shared library used
> by GnuTLS.  Could it be that you have an incompatible binary of that
> library?
>
> In any case, the problem doesn't seem to be in Emacs.

It's been over ten weeks with no response, so I'm going to close this
bug. If you need further help you can still reply to this, or it might
be worth checking with the Emacs for OS X people to see if there are any
pre-requisites.
-- 
Alan Third





reply via email to

[Prev in Thread] Current Thread [Next in Thread]