bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25830: 25.2; ispell doesn't parse hunspell dictionaries properly


From: Eli Zaretskii
Subject: bug#25830: 25.2; ispell doesn't parse hunspell dictionaries properly
Date: Tue, 21 Feb 2017 22:44:03 +0200

> Date: Tue, 21 Feb 2017 21:24:54 +0100
> From: Martin Kletzander <address@hidden>
> Cc: address@hidden
> 
> I have multiple dictionaries installed.  Hunspell finds all of them, but
> selects *two* of them.  According to the man page, that is done
> according to LC_ALL, LC_MESSAGES, and LANG environment variables.

What are the values of those environment variables?

> Becuase hunspell selects more of them (which is something I want it to
> do), it lists both of them as "LOADED DICTIONARY", ispell parses those
> (actually just lines ending with ".aff") and if it finds more than one,
> it errors out.

The way to run Hunspell with more than one dictionary is hinted upon
in the doc string of the command ispell-hunspell-add-multi-dic.  After
you invoke that command and specify the dictionaries you want to use
(e.g., in your case "en_GB,cs_CZ"), type this:

  M-x ispell-change-dictionary RET en_GB,cs_CZ RET

Then try spell-checking.  It should work with that arrangement.  It is
possible that you will first need to modify your environment variables
to prevent Hunspell from loading more than one dictionary by default.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]