bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25279: 26.0.50; Slowdown/crash on certain characters


From: Eli Zaretskii
Subject: bug#25279: 26.0.50; Slowdown/crash on certain characters
Date: Mon, 26 Dec 2016 22:49:00 +0200

> From: Richard Copley <address@hidden>
> Date: Mon, 26 Dec 2016 20:40:42 +0000
> Cc: address@hidden
> 
> > Because you don't have Symbola installed, I guess.  The fonts Emacs
> > finds for displaying these characters all have non-Unicode registry
> > fields, and that causes Emacs to desperately look for a Unicode font
> > each time it needs to display one of these characters.
> 
> OK, thanks, but I don't quite follow, sorry. Unless you're saying there's a
> non-desperate mechanism that's usually used but which fails unless a
> font with a Unicode registry field is found for the character?

When Emacs doesn't find a font with a Unicode registry, it looks in
many fonts trying many alternative registries.  Each font is tried
twice, ones with the Uniscribe back-end, the other one with the GDI
back-end.  All of that does a lot of consing, so the next GC comes
soon, and compacts font caches by deleting all that information.  Then
the next time redisplay kicks in, it searches all of those fonts
again, and again conses a lot, which again causes GC.  Etc. etc.

> Commendably thorough, but causes the editor to grind to a halt and crash
> in some circumstances.

A crash shouldn't happen in any case, so if you can show a recipe and
a backtrace, maybe this could be fixed.

Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]