bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25218: flyspell.el tidy-up: remove XEmacs support and fix a spelling


From: Agustin Martin
Subject: bug#25218: flyspell.el tidy-up: remove XEmacs support and fix a spelling mistake
Date: Mon, 19 Dec 2016 19:45:02 +0100

2016-12-17 20:14 GMT+01:00 Reuben Thomas <address@hidden>:
The attached patches remove XEmacs support from flyspell.el (flyspell.el has been an integral part of GNU Emacs for some time, so our version does not need to support XEmacs), and renames an internal defun whose name was incorrectly spelt: flyspell-ajust-cursor-point (ajust → adjust).

Thanks for dealing with this,

For some time I tried to keep ispell.el and flyspell.el supporting XEmacs, so I could use the same file with minimal patches in Debian. However, since ispell.el and flyspell.el started using the cl- stuff this was no longer possible (hopefully for good), so Debian Emacs uses now its own ispell.el and flyspell.el and XEmacs old stuff still provided by dictionaries.common Debian package.

So I agree that it is no longer meaningful to keep XEmacs stuff flying around.

--
Agustin




reply via email to

[Prev in Thread] Current Thread [Next in Thread]